DevTech101

DevTech101

Month: November 2013

Modifying Solaris Zone Properties With a Loop.

Modifying Solaris Zone Properties With a Loop. To modify many Solaris Zone Properties, you can run a loop something like the below. Example 1 for i in `zoneadm list -cv |grep wapp1|awk ‘{print $2}’`;do ipaddr=`zonecfg -z $i info anet |grep “allowed-address: 10″|awk ‘{print $2}’|sed ‘s,10.20.19,10.20.41,’`; zonecfg -z $i “add anet;set lower-link=webpriv0;set allowed-address=$ipaddr;end;commit” ;done Example 2 …

Modifying Solaris Zone Properties With a Loop. Read More »

Protecting Files From Getting Overwritten Mistakenly

Protecting Files From Overwriting Mistakenly To set protection on, run the below. set -o noclobber To make it permanent just add to your .bashrc echo ‘set -o noclobber’ >> ~/.bashrc An example how things will work after noclobber is set. $ echo test > testfile1 bash: testfile1: cannot overwrite existing file To forcibly overwrite the …

Protecting Files From Getting Overwritten Mistakenly Read More »

Backup tuning

Run onthe zone ipadm set-prop -p max_buf=16777216 tcp ipadm set-prop -p _cwnd_max=8388608 tcp ipadm set-prop -p send_buf=2097152 tcp ipadm set-prop -p recv_buf=2097152 tcp ipadm set-prop -p _conn_req_max_q=16384 tcp ipadm set-prop -p _conn_req_max_q0=16384 tcp Add to /etc/system on global zone set ip:ip_squeue_fanout=1 set ip:ip_soft_rings_cnt =32

Solaris 11, Korn Shell 93 COMPATIBILITY

In Oracle Solaris 11, Korn Shell 93 (/usr/bin/ksh/ or usr/bin/ksh93) replaces both the Bourne Shell (/usr/bin/sh or /sbin/sh) and Korn Shell 88 (/usr/bin/ksh). There are some incompatibilities between the shells. They are described in: /usr/share/doc/ksh/COMPATIBILITY If a script has compatibility problems you can use the legacy shell by changing the she-bang line: If this doesn't …

Solaris 11, Korn Shell 93 COMPATIBILITY Read More »

How to Locate Oracle Sun Server Using Locator LED

Web Procedure – Enable or Disable Locate LED In the web interface, click System Monitoring –> Indicators. In the Actions list box, click Name: Locate. To illuminate the Locator LED, select the radio button adjacent to /SYS/LOCATE, and then click Set LED to Fast Blink. To disable the Locator LED, select the radio button adjacent …

How to Locate Oracle Sun Server Using Locator LED Read More »

Allow 32bit applications on 64bit RedHat/OEL

If you don't install 32bit OS librrey's you might get errors like this. perl  perl: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.2.5, not stripped To fix this issue you will need to install at miniumem the system 32bit libryrys yum install glibc.i686